microscopic fonts in TL guis

Jim Diamond Jim.Diamond at acadiau.ca
Thu Apr 9 16:13:57 CEST 2020

Hi Zdenek,

On Thu, Apr  9, 2020 at 08:25 (+0200), Zdenek Wagner wrote:

> I do not have TL 2020 so far, I have just tried tlcockpit from TL 2019. It says:

> Running on Java Version 1.8.0_131

> I do not have GDK_SCALE set. In fact, I run KDE Plasma. I do not have
> Gnome, I only have the GTK libraries installed because gimp and a few
> other apps need them. I see the fonts in a reasonable size. It can
> depend on setting the resolution of the screen. I have a correct
> setting in my system.

"Correct" setting seems to be in the eye of the beholder.

I think "correct" means "if the screen is physically X DPI, then X
should report X".  Other people seem to think "correct" means "96,
regardless of what reality is".

I consider the latter to be a horrible kludge which has become popular
because it is expedient, but YMMV.



> čt 9. 4. 2020 v 4:51 odesílatel Norbert Preining <norbert at preining.info> napsal:

>> Hi Jim,

>>> > You can fix it *probably* by doing
>>> > GDK_SCALE=2 tlcockpit

>>> Thanks for the suggestion.  However, as it turns out, I already have
>>> GDK_SCALE=2 in my environment.

>> That is strange... but not completely unexpected.
>> Which Java Version do you have installed?

>> Norbert

>> --
>> PREINING Norbert                              https://www.preining.info
>> Accelia Inc. + IFMGA ProGuide + TU Wien + JAIST + TeX Live + Debian Dev
>> GPG: 0x860CDC13   fp: F7D8 A928 26E3 16A1 9FA0 ACF0 6CAC A448 860C DC13

Dr. Jim Diamond       "Convenio ergo sum"      |                        /"\
Jodrey School of Computer Science              | ASCII Ribbon Campaign  \ /
Acadia University, Wolfville NS Canada B4P 2R6 |  http://arc.pasp.de/    x
Voice: (902) 585-1402    Fax: (902) 585-1067   |                        / \

More information about the tex-live mailing list.