[tex-live] config files for fmtutil

Herbert Schulz herbs at wideopenwest.com
Wed Aug 19 13:16:50 CEST 2015

> On Aug 19, 2015, at 4:03 AM, Zdenek Wagner <zdenek.wagner at gmail.com> wrote:
> Hi Norbert,
> sorry for my confusing emails, I will try to summarize it.
> 1. During pretest I tried on two x86_64 computers with Fedora and on Raspberry Pi and my local fmtutil.cnf was read and encTeX was activated.
> 2. On my home computer (x86_64 with Fedora) everything works fine but the latest "tlmgr update" was run on July 31 in the evening.
> 3. Yesterday I found that in my office computer encTeX is not enabled (I did not notice earlier because I do almost everything in XeLaTeX now). I did the following:
> a) verified that I have the right fmtutil.cnf saved as /usr/local/texlive/texmf-local/web2c/fmtutil.cnf
> b) ran mktexlsr
> c) ran fmtutil-sys --all
> Nothing changed, no support for encTeX, thus I tried to update by
> tlmgr update -self --all
> The result was the same.
> I verified again that my local fmtutil.cnf is right and ran:
> mktexlsr
> fmtutil-sys --byfmt pdflatex
> Here I immediatelly see that the line from my fmtutil.cnf is not used.
> After coming home I checked that I really use TL 2015 on both computers. I mounted /usr/local/texlive/2015 from my office computer via sshfs, compared fmtutil.pl and diff showed that the file is identical in both computers. Thus I do not understand what might have happened.
> Zdeněk Wagner
> http://ttsm.icpf.cas.cz/team/wagner.shtml
> http://icebearsoft.euweb.cz
> 2015-08-19 2:29 GMT+02:00 Norbert Preining <preining at logic.at>:
> Hi Zdenek,
> I am a bit unclear about how I should understand this email:
> On Tue, 18 Aug 2015, Zdenek Wagner wrote:
> > I have just come home. I see that the formats here were last generated on
> > July 31 at 21:45 CES (summer time, i.e. +2:00) and my local fmtutil.cnf was
> > honoured and encTeX is active.
> Does that mean all is fine? Ir do you see something missing?
> Norbert


I don't know if this is important but in one email Zdeněk also said
kpsewhich finds consistently only this one on both systems:

which I find strange since on one system the custom build seems to work fine.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the tex-live mailing list