[tex-live] Got logreq but fontspec...

George N. White III gnwiii at gmail.com
Sun Sep 12 16:19:07 CEST 2010

On Sun, Sep 12, 2010 at 10:37 AM, Herbert Schulz <herbs at wideopenwest.com> wrote:
> On Sep 12, 2010, at 8:17 AM, Robin Fairbairns wrote:
>> Herbert Schulz <herbs at wideopenwest.com> wrote:
>>> I also got an update to fontspec but it turned out to still be 2.0b
>>> while the latest version on CTAN is 2.0c which fixes a problem with
>>> visible spaces in verbatim* environments.
>> what mirror do you use as repository?
>> the tl fontspec update was on ctan 0200-ish (uk time) yesterday, and
>> even allowing for the delay getting to dante.ctan or tug.ctan, it really
>> ought to be on mirrors by now.
>> we tend to remove mirrors from the list, if they're consistently >1day
>> behind the ctan they mirror from: if they're not on the list, they don't
>> get selected by the mirror selector, and ...
>> robin the eternally worried.
> Howdy,
> More information:
> If I run
> tlmgr show fontspec
> I get
> package:     fontspec
> category:    Package
> shortdesc:   Advanced font selection in XeLaTeX and LuaLaTeX.
> longdesc:    Fontspec is a package for XeLaTeX and LuaLaTeX. It provides an automatic and unified interface to feature-rich AAT and OpenType fonts through the NFSS in LaTeX running on XeTeX or LuaTeX engines.
> installed:   Yes
> revision:    19649
> cat-version: v2.0c
> cat-date:    2010-08-01 19:08:30 +0200
> cat-license: lppl1.3
> collection:  collection-xetex
> so the database is showing the correct version but if I actually check the fontspec version directly I get 2.0b. Could tlmgr have actually not updated the files?

I'm in the same situation.  I tried "remove -force" and then "install":

$ tlmgr --repo http://www.tex.ac.uk/tex-archive/systems/texlive/tlnet
remove --force fontspec
tlmgr: fontspec is needed by collection-xetex unicode-math
tlmgr: removing it anyway, due to --force
remove fontspec
tlmgr: actually removed these packages: fontspec
tlmgr: package log updated at /usr/local/texlive/2010/texmf-var/web2c/tlmgr.log
running mktexlsr ...
done running mktexlsr.
wendigo:fontspec gwhite$ tlmgr --repo
http://www.tex.ac.uk/tex-archive/systems/texlive/tlnet install
tlmgr: package repository http://www.tex.ac.uk/tex-archive/systems/texlive/tlnet
[1/1, ??:??/??:??] install: fontspec [2763k]
tlmgr: package log updated at /usr/local/texlive/2010/texmf-var/web2c/tlmgr.log
running mktexlsr ...
done running mktexlsr.

and still have 0.2b files with the databse showing 0.2c.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list