[tex-live] TL'10 pretest trial

George N. White III gnwiii at gmail.com
Tue May 25 20:28:29 CEST 2010

On Tue, May 25, 2010 at 11:51 AM, Taco Hoekwater <taco at elvenkind.com> wrote:
> Hi,
> Karl Berry wrote:
>> Give it a try if you're willing.
> I just tried a network install of the context scheme. First, the
> very good news: both context mkii and mkiv are close to perfect,
> based on the tests I have done so far.
> Nevertheless, some requests and remarks, in order of importance:
> * it would be really nice if the tl installer could be made to run
>  an initial
>        luatools --generate
>  in post-install because otherwise the 'context' command does
>  not work out of the box.
> * fmtutil does not want to generate the context mkii formats, even
>  though they are defined in fmtutil.cfg. Maybe this is because there
>  are two entries with the same name?
> * it would be even nicer if fmtutil could be made to support mkiv
>  formats as well. The creation command is:
>  context --make [en|nl|fr|ro|de|it]
>  [|] == alternate choices

Is there an equivalent to the "-sys" with "context --make"?

>  even just 'en' would be really nice to have.
> * assuming the final version will keep shell_escape=p: can 'mpost'
>  please be added to the list of acceptable commands? otherwise
>  we will have to ask all context users to add shell_escape=t
>  by themselves
> * because $TEXMFCACHE is not set in texmf.cnf, the context luatex-cache
>  folder ends up in my $TMP directory (but that's ok, it works)

On linux, I don't have $TMP set, just $TMPDIR, and I ended up with
~/luatex-cache.   Since the cache depends on the contents of the
texmf trees, the cache should go to something like ~/.texlive2010
so as not to confuse TL2011 (I suppose we could leave TL2010
alone and remember to adjust TL2011).

> * perhaps the pxfonts and txfonts packages can be added into
>  scheme-context. context uses these for math in the default 'palatino'
>  and 'times' typescripts.
> Finally (but maybe that is just me):
> * in tlmgr --gui, it was not at all obvious to me that you can click on
>  the 'Loaded repository: none' to actually load a repository.

I have been using "tlmgr --repository ... --gui", but if I run the new
tlmgr without setting --repository on a system with MacTeX (TL2009)
installed, the repository set for MacTeX is used.   Does this mean
the installer could get confused on systems with pre-existing
TL installs?   Where is the repository setting saved?

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list