[tex-live] $TEXMFHOME not working right

Vladimir Lomov lomov.vl at gmail.com
Fri May 14 06:58:56 CEST 2010

** Joel C. Salomon [2010-05-13 23:44:05 -0400]:

> I have a net install of TL ’09 on my Ubuntu machine, installed for the
> whole machine (so I run tlmgr under sudo).  I’m trying to install some
> packages in $TEXMFHOME, but they are not being found.  Running mktexlsr,
> either as root or not, does not update that tree, so I tried doing it
> explicitly:

> chesky at derrial:~$ mktexlsr --verbose `kpsewhich --expand-var='$TEXMFHOME'`
> mktexlsr: Updating /home/chesky/texmf/ls-R...
> mktexlsr: Done.

> The ls-R file is created, but .sty files are still not found for
> typesetting.

$ kpsewhich YOURSTYLEFILE.sty

> I looked for an option in tlmgr for $TEXMFHOME (I vaguely recall such an
> option in the installer?) but could not find it.

> Is there a configuration file to edit to fix this?

Please keep in mind that TeX Live is TDS compliant distro.

Suppose you have 'my-priv.sty' package. You should place it here:
          (any sensible name is ok)

After that if you run
$ kpsewhich my-priv.sty
you should get
($HOME will be expanded)

Is death legally binding?

More information about the tex-live mailing list