[tex-live] Problem in updating texlive-2009

George N. White III gnwiii at gmail.com
Wed Jul 28 16:10:31 CEST 2010

On Wed, Jul 28, 2010 at 4:58 AM, S. venkataraman <svenkat at ignou.ac.in> wrote:

> I have upgraded to ubuntu 10.04 and so
> I reinstalled texlive-2009. I have problems updating.

Did you install the CTAN version or use the Ubuntu packages?

> Since there was a problem in updating using the original gui,
> I updated it by downloading and installing a fresh version of tlmgr using
> the
> shell file given in the tex repository. The problems still persist.
> If I try to set the remote repository using gui,
> I get the following error message:
> *************************
> Use of uninitialized value $defaults{"backupdir"} in string ne at
> /opt/texlive/2009/texmf/scripts/texlive/tlmgrgui.pl line 1112.
> Use of uninitialized value in string ne at
> /opt/texlive/2009/texmf/scripts/texlive/tlmgrgui.pl line 1112.
> Use of uninitialized value $defaults{"autobackup"} in string ne at
> /opt/texlive/2009/texmf/scripts/texlive/tlmgrgui.pl line 1112.
> Use of uninitialized value in string ne at
> /opt/texlive/2009/texmf/scripts/texlive/tlmgrgui.pl line 1112.
> *************************

It would be useful for the record to see the versions of the
various programs you mention.

You might consider using TL2010.   It is quite possible that something
in Ubuntu 10.4 causes a problem in the 2009 tlmgr, but since the
developers are concentrating on TL2010, resolving such problems
may be a low priority.

> I tried to update using command line. I get the following message:
> ****************************
> sudo tlmgr update --all -repository
> ftp://dante.ctan.org/tex-archive/systems/texlive/tlnet
> tlmgr: package repository
> ftp://dante.ctan.org/tex-archive/systems/texlive/tlnet
> TLDownload::get_file: response error:
>   500 LWP::Protocol::MyFTP: connect: Connection timed out
> permanent server connection set up, but downloading did not succeed!Retrying
> with wget.
> ***************************
> The proxy server doesn't seem to be a problem. Aptitude is able to download
> debian packages.

The "unitialized variables" problem may prevent you from getting to
this stage, but
AFAIK, the gui and commandline versions use the same code to download the

aptitude is likely using different servers, protocols, and settings.
For me, aptitude
often fails when tlmgr is working, so there is very little reason to
think success with
aptitude implies success with tlmgr or vv.

Have you tried other CTAN servers?   You may have better luck using http.

> What is the solution this problem?
> Best,
> S. Venkataraman

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list