[tex-live] ./install-tl bugs from TexLive 2008 on OpenSolaris

Jordan L. Kovitz jordan.kovitz at me.com
Tue May 26 20:04:15 CEST 2009

Dear Mr. Exterminator:

I downloaded the file texlive2008.iso.lzma from your site and then
verified the file by its checksums.

Then I extracted the file texlive2008.iso to a working directory on the
hard disk of computer running OpenSolaris.  I then created another
working directory and used a utility to extract the contents of the iso
file into that directory.  I recognize that files in the iso are no
longer compressed, but the utility uses its extract command to treat iso
files as if they were tarballs and the like.

I then opened a terminal and navigated to the second working directory
described above.  This directory corresponds to the main directory on
the DVD image and contains the install-tl file.

One quirk of OpenSolaris is that its default system shell is ksh93.  I
learned the hard way that many scripts assume the system shell is bash,
so I set the system shell to bash.  Then I execute su to gain root-level
access.  Then I executed unalias -a in case your scripts forget to do

I then entered ./install-tl and received the error message:
bash: ./install-tl: Permission denied

I then checked the permissions on install-tl, and found them to be set
to -rw-------.  Well, the obvious fix here is chmod u+x install-tl.

I then re-entered ./install.tl and received another error message: 

jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD# ./install-tl
TeXLive::TLUtils::setup_programs failed at tlpkg/TeXLive/TLUtils.pm line
./tlpkg/installer/lzma/lzmadec.i386-solaris --help failed (status
32256): No such file or directory
Output is:
Can't exec "./tlpkg/installer/lzma/lzmadec.i386-solaris": Permission
denied at tlpkg/TeXLive/TLUtils.pm line 1045.
Couldn't set up the necessary programs.
Cannot continue with installation.
Please report to texlive at tug.org.
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD#

OK, so I report it.  But I also solved it in another terminal window:

jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/tlpkg/installer/lzma$ ls
lzma.alpha-linux       lzmadec.powerpc-aix       lzma.i386-linux
lzma.amd64-freebsd     lzmadec.powerpc-linux     lzma.i386-openbsd
lzmadec.alpha-linux    lzmadec.sparc-linux       lzma.i386-solaris
lzmadec.amd64-freebsd  lzmadec.sparc-solaris     lzma.mips-irix
lzmadec.hppa-hpux      lzmadec.universal-darwin  lzma.powerpc-aix
lzmadec.i386-freebsd   lzmadec.win32.exe         lzma.powerpc-linux
lzmadec.i386-linux     lzmadec.x86_64-linux      lzma.sparc-linux
lzmadec.i386-openbsd   lzma.exe                  lzma.sparc-solaris
lzmadec.i386-solaris   lzma.hppa-hpux            lzma.universal-darwin
lzmadec.mips-irix      lzma.i386-freebsd         lzma.x86_64-linux
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/tlpkg/installer/lzma$ ls -l lzmadec.i386-solaris 
-rw------- 1 jkovitz staff 10956 2008-05-20 21:18 lzmadec.i386-solaris
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/tlpkg/installer/lzma$ chmod u+x lzmadec.i386-solaris
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/tlpkg/installer/lzma$ ls -l lzmadec.i386-solaris 
-rwx------ 1 jkovitz staff 10956 2008-05-20 21:18 lzmadec.i386-solaris*
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/tlpkg/installer/lzma$ 

Executing ./install.tl from root as before now brings up the TeX Live
installation procedure screen.  I then selected o and then p to change
the default paper size to letter from A4.  I next selected l to request
creation of symbolic links in respective subdirectories of /usr/local.
Next selecting r returned me to the main screen.  The remaining default
options are acceptable to me, so I then entered i to begin the

The installation procedure went along fine until:

Installing: contour
Installing: cooking
Installing: cool
Installing: coollist
Installing: coolstr
Installing: cooltooltips
Installing: coordsys
Can't open
'/export/home/jkovitz/installation/TexLive/texlive2008_DVD/texmf-dist/doc/latex/coordsys/putfile.': No such file or directory
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD# 

The obvious thing to do was to check the directory:

jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/texmf-dist/doc/latex/coordsys$ ls -l
total 394
-rw------- 1 jkovitz staff 340552 2006-11-09 09:18 coordsys.pdf
-rw------- 1 jkovitz staff   5738 2006-11-09 09:18 putfile
-rw------- 1 jkovitz staff    412 2006-11-09 09:18 README
jkovitz at OpenSolaris:~/installation/TexLive/texlive2008_DVD/texmf-dist/doc/latex/coordsys$ 

So the file is there.  Changing its permissions by chmod u+x returned
the same error message.

Now I'm stuck.  Please help!


Jordan L. Kovitz

More information about the tex-live mailing list