[tex-live] pool files integrated into all binaries

Jonathan Kew jonathan_kew at sil.org
Wed Mar 26 16:16:32 CET 2008

On 26 Mar 2008, at 2:14 pm, Jonathan Kew wrote:

> On 25 Mar 2008, at 6:38 pm, Karl Berry wrote:
>> Thanks to Akira, the pool files for tex, mf, and etex (not that we
>> install the separate etex binary any more) along with aleph and  
>> omega,
>> are now compiled into the binaries, using the technique that Taco
>> developed some time ago for mpost, luatex, pdftex.
>> The result should be no more painful "tangle me again" messages.   
>> We can
>> hope, anyway.
>> karl
> I'm afraid this seems broken, at least for me.... Build runs into  
> errors beginning with Metafont:
> gcc -g -O2  -c -o mf-mkcpool.o ../../../texk/web2c/mf-mkcpool.c
> gcc -g -O2  -o mf-mkcpool mf-mkcpool.o
> ./mf-mkcpool mf.pool ../../../texk/web2c/tmf-pool.h >mf-pool.c
> gcc -g -O2  -I. -I.. -I../../../texk/web2c -DMETA_FONT -c -o mf- 
> pool.o mf-pool.c
> In file included from ../../../texk/web2c/cpascal.h:16,
>                  from ../../../texk/web2c/texmfmp.h:5,
>                  from ./mfd.h:10,
>                  from ../../../texk/web2c/tmf-pool.h:15,
>                  from mf-pool.c:4:
> ../../../texk/web2c/config.h:32:29: error: kpathsea/config.h: No  
> such file or directory

That was on Mac OS X (10.4.11). I tried it on Linux (Ubuntu Gutsy)  
and it build OK... weird. On looking into the Makefile, I think it  
should have an additional -I$(srcdir)/.. in the rule that compiles mf- 
pool.c. I've added this in TL and it now builds on OS X as well.

(I'm still not really sure why the difference. To me, it looks like  
all platforms ought to need the extra include path, but I don't  
really understand all the rules.)


More information about the tex-live mailing list