[tex-live] TeXLive 2003 on a FAT32 file system

Alois Steindl Alois.Steindl at tuwien.ac.at
Mon May 17 12:00:02 CEST 2004

I tried to install the new TeXLive version in a FAT32 partition for both
Linux and Win2000. Since FAT32 doesn't accept symbolic links in Linux, I
created a small directory ~/TeXLive/bin and put there all symbolic 
links, for example
~/TeXLive/bin/latex -> /dosdisk/TeXLive/bin/i386-linux/etex
and included ~/TeXLive/bin in my PATH.
Now I face a rather strange problem, when I run latex:

latex scr
lstat(./latex) failed ...
./latex: No such file or directory
This is e-TeX, Version 3.14159-2.1 (Web2C 7.3.7x)
kpathsea: Running mktexfmt latex.efmt

If I call latex with its path, it runs fine. Even more strange: If I 
call latex from the tcsh, then it also runs fine, the problem occurs for 
bash. I upgraded bash to the most recent version, but it didn't change.

If I put a link to latex into the current directory, it is also fine.

It seems that the problem is somehow caused by the following lines in

if (lstat (pre, &st) != 0) {
fprintf (stderr, "lstat(%s) failed ...\n", pre);
perror (pre);
return NULL;

 From here on no environment variables are found, so texmf.cnf is missed.
Of course I do not understand why it works from the tcsh.

Can the team give any recommendations how to install TeXLive on dual 
boot machines?

Could the TeXLive team maybe rethink its handling of symbolic links? 
These links are very fine in a pure unixoid environment, but especially 
in TeXLive, which is very convenient for dual-boot systems, they cause 

Best regards
Alois Steindl

PS.: I did send this mail already end of march, but I guess that it 
didn't go through, since I did not sign up.

More information about the tex-live mailing list