[tex-live] Comments on TeXLive 6 CD

Staszek Wawrykiewicz StaW@gust.org.pl
Thu, 26 Jul 2001 05:06:00 +0200 (CEST)

Evgeny Rupakov writes:
 >  I'd like to comment my TeXLive 6 CD installation experience on
 > Win32 (specifically, Windows98 SE) platform.

Sebastian Rahtz answered:
> the Windows guru, Fabrice Popineau, is on holiday, and I fear that
> no-one else can answer questions. did you get the very latest release,
> of July 22nd?

I tested installation of TL6 20010722 on:
1. Windows 2000
2. Windows NT 4.0 (with service pack 5)
3. Windows 95 OSR2 (UK version on HP notebook)
4. Windows 95 (with updated DLL)
5. Windows 98 SE

Most of the problems reported by Evgeny Rupakov are resolved!
Great thanks for Fabrice!!!
I cannot answer questions concerning TeXnic Center. As I see, it is not
supported anymore, please try WinShell instead (quite nice, but still not
so robust, the version on the CD is *the special version* not to be found
on the net ;-)). NTEmacs works well even on win95. Please have in mind
that all such programs (Emacs, winshell, texnic center, etc.)
are *additional* programs included for TL as Windows doesn't offer
nothing more than notepad. Please send any questions concerning those
programs to the respective Authors.
We are always waiting for *good*, *free*, small and smart editor for TeX
beginers using Windows. I have perhaps a good candidate (born in Poland),
but it is still not enought ready for promotion. So we have on the CD
only some examples of such additional applications.

Testing on Linux (RH6.1 with updated libraries, RH7.1) is OK.
The only problem is adding some packages after normal installation, e.g.
 sh install-pkg.sh --package=metapost
installs well only the contents of texmf tree, without binaries!
I even tried
 sh install-pkg.sh --collection=tex-metapost
the same result. It is really drawback as we consider that recommended
installation doesn't include metapost (as it was 2 months ago ;-}
Sebastian, it seems that install-pkg.sh doesn't parse .tpm's binaries part.
On Windows it works OK (texsetup --add-package=xxx).

I am completelly messed with psfonts.map for dvips and pdftex.
In short: I tried to make pdf file from some document received...
TL setup gives:
 Warning: pdflatex.exe (file ptmro8r): Font ptmro8r at 657 not found
so the resulting .pdf file is broken, but the same document
on MiKTeX2.0 loads smoothly:
Investigating it, I found for TL in dvips/config/psfonts.map only!:
ptmro8r Times-Roman ".167 SlantFont TeXBase1Encoding ReEncodeFont" <8r.enc
(the line not included at all in pdftex/config/psfonts.map)
 but for MiKTeX in pdftex/config/psfonts.map:
ptmro8r NimbusRomNo9L-Regu ".167 SlantFont TeXBase1Encoding ReEncodeFont" <8r.enc <utmr8a.pfb

Who can explain me such a mess?

Staszek Wawrykiewicz
email: staw@gust.org.pl