[metapost] problems with memory in metapost

Yogeshwarsing Calleecharan yogeshwarsing.calleecharan at ltu.se
Sat May 8 10:33:06 CEST 2010

      I've been able to make it work. I remembered that I issued the 
command fmtutil --byfmt mpost when I updated my TL2008 to metapost 1.208 
. I re issued the same command and then tried again the conversion of 
the mp file to eps and it worked:

E:\paper1\may06\fotos\rplots\gnup\k03>mpost --sprologues=3 
-%c.eps\" myfigu.mp
This is MetaPost, version 1.208 (kpathsea version 3.5.7dev)
.pfb>] )
1 output file written: myfigu-1.eps
Transcript written on myfigu.log.

Now, I have a small question: The mp file was about 4 MB while the 
generated eps file is about 23 MB! How to make this eps file smaller? I 
can't submit such a big size eps to a journal via email.

I tried with Matlab and laprint and the generated eps file is about 6MB.

PS: I tried again kpsewhich mpost.mem and this still doesn't work.


Best Regards,

On 5/8/2010 9:36 AM, Taco Hoekwater wrote:
> Yogeshwarsing Calleecharan wrote:
>> Hi,
>>     Thanks you for your very kind help. However it's still not working. I
>> have TexLive 2008 on a Win XP machine and I upgraded to metapost 1.208
>> some months back. This is what I did:
>> 1. ran kpsewhich mpost.mem from the directory holding figu.mp
>> E:\paper1\may06\fotos\rplots\gnup\k03>kpsewhich mpost.mem
>> E:\paper1\may06\fotos\rplots\gnup\k03>
>> Nothing happens. I don't get any message. However if I look for
>> texmf.cnf say I do get
> Sorry, I have no idea.
> Taco

More information about the metapost mailing list