[metapost] how to use mpstoeps on a Windows machine

Dan&Jan Luecking luecking at uark.edu
Thu Dec 3 06:40:49 CET 2009

At 03:11 PM 12/2/2009, you wrote:
>Content-class: urn:content-classes:message
>Content-Type: multipart/alternative;
>         boundary="----_=_NextPart_001_01CA7394.11B41EC5"
>Hi again,
>          I tried to install the new metapost on TL2008 on my 
> Windows machine. I pick the mpost.exe from the windows file 
> (mingw.zip) at 
> <http://foundry.supelec.fr/gf/project/metapost/frs/>http://foundry.supelec.fr/gf/project/metapost/frs/ 
> and replaced the old mpost.exe (v1.005) in my TL2008 with this new 
> mpost.exe (v1.208). Then I ran the command:
>fmtutil --byfmt mpost
>which I found in an earlier thread. I got: Ok. mpost.exe exists and 
>mypost.mem is created.
>I then try to run the new mpost.exe on my mp file. First with the 
>single quotes as you originally gave me and then without the single 
>quotes as you also suggested. I have a Win XP machine. Here are the outputs:
>E:\testing\gn\test35\labe>mpost --sprologues=3 
>-soutputtemplate='"%j-%c.eps"' my

This is windows, where % signs introduce environmental variables.
Also, quotes tend to be stripped from command line arguments.
After several failed attempts, I discovered the following works
in a cmd.exe window:

mpost -soutputtemplate:=\"%j-%c.eps\" myfigu.mp

While the following works in my usual command window (4NT.exe):

mpost -soutputtemplate:=\"%%j-%%c.eps\" myfigu.mp

I have another windows shell (TCC) on another computer
which I will test tomorrow. But one or the other of these
should work.


Dan Luecking
Fayetteville, Arkansas 

More information about the metapost mailing list