[metapost] Metapost beta 1.091 release

Taco Hoekwater taco at elvenkind.com
Wed Jul 30 10:44:48 CEST 2008

Hi Laurence,

Laurence Finston wrote:
> Hello Taco et al,
> I installed the beta release 1.091 today, but had some problems 
> you might want to know about.  I hope I've remembered everything.
> I've also tried to resubscribe to this list, but I haven't gotten the 
> confirmation email and it's been quite a while now.  So, if anyone
> wants to reply, please "cc" it to my address, or I might not 
> get it, depending on how long it takes to get subscribed.

Long time no see. I guess you're in now because the message got through.

> I got this error message:
> ls: build/texk/web2c/mpdir/.libs/mplib.so: No such file or directory
> It turns out that it's harmless, but it did cause `build.sh' to exit
> with a non-zero exit status and I wasn't sure whether it was important.

This is the lua mplib extension module, I should make building and
listing that an option to the build script, that would be better.

> I also got this error:
> creating ../kpathsea/libkpathsea.la
> (cd ../kpathsea/.libs && rm -f libkpathsea.la && ln -s ../libkpathsea.la libkpathsea.la)
> ./ctangle ctangle 
> make: ./ctangle: Command not found
> make: *** [ctangle.c] Error 127

Will fix.

> When I tried to typeset a label, I got this error:
> ! Font cmr10 not usable: TFM file not found.
> thelabel->...se:p=(EXPR3)infont.defaultfont.scaled
>                                                   .defaultscale.fi;p.shifted...
> I was able to fix it by setting and exporting the environment variable
> `TEXMF' to a path with the directory `texmf' in it.

This is probably normal. Whether or not copying of texmf.cnf works
depends on the actual contents of that texmf.cnf. In your case,
it probably contained relative paths instead of absolute ones.

Thanks for the report and best wishes,

More information about the metapost mailing list