[metapost] Metapost beta 1.091 release

Laurence Finston lfinsto1 at gwdg.de
Tue Jul 29 19:45:11 CEST 2008

Hello Taco et al,

I installed the beta release 1.091 today, but had some problems 
you might want to know about.  I hope I've remembered everything.

I've also tried to resubscribe to this list, but I haven't gotten the 
confirmation email and it's been quite a while now.  So, if anyone
wants to reply, please "cc" it to my address, or I might not 
get it, depending on how long it takes to get subscribed.

I got this error message:
ls: build/texk/web2c/mpdir/.libs/mplib.so: No such file or directory

It turns out that it's harmless, but it did cause `build.sh' to exit
with a non-zero exit status and I wasn't sure whether it was important.

I also got this error:

creating ../kpathsea/libkpathsea.la
(cd ../kpathsea/.libs && rm -f libkpathsea.la && ln -s ../libkpathsea.la libkpathsea.la)
./ctangle ctangle 
make: ./ctangle: Command not found
make: *** [ctangle.c] Error 127

I solved this problem by copying `ctangle' into the directory
mplib-beta-1.091/src/texk/web2c/cwebdir/ from somewhere else.

I then had problems with `texmf.cnf' and `mpost.mem'.  I copied a 
`texmf.cnf' file to my working directory from somewhere else and
managed to figure out how to generate `mpost.mem' from `mpost.mp'.
I couldn't find an `INIMP' but found a reference to the `-ini' option
to `mpost' by using `grep' and used that.  

When I tried to typeset a label, I got this error:

! Font cmr10 not usable: TFM file not found.

I was able to fix it by setting and exporting the environment variable
`TEXMF' to a path with the directory `texmf' in it.

I hope you find this information useful.

Laurence Finston

More information about the metapost mailing list